Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
asyamilos
19.05.2022 06:26 •
Информатика
Дано натуральное трехзначное число n. составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч).
Показать ответ
Ответ:
nbis2000
08.07.2020 21:19
Program Pr1;
uses crt;
var fl1,fl2:text;
n,tmp:string;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
close(fl1);
tmp:=copy(n,length(n),1);
n:=tmp+n;
rewrite(fl2);
writeln(fl2,n);
close(fl2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
rran
30.05.2021 17:27
Запишите программный код вычисления значения функции х2, если х 0 у = х + 7, если х = 0 x = int(input(“введите х:”))...
Алалутала
16.01.2022 12:31
Уровень А (найти остатки от деления) print (8%2) print (9%2) print (13.5%5) 1 3,1999999.. 0 ___ В-уровень (вычисление целой части в делителе и вычисление степени) print (21//4) print...
Coul2000nator
15.07.2021 23:01
ЭТО КОНТРОЛЬНАЯ ТОК ПРАВИЛЬНО...
Ayazoro2
04.06.2020 10:55
Задания .Найти сумму цифр данного натурального числа, заполните трассировочную таблицу n =int(input(‘)) s =0 while s!=0 k =n%10 s =s+k n =n//10 print( berilgen sannyn sfifirlarynyn...
arishatopic
26.08.2021 05:45
4. Определите типы данных. Правильный ответ подчеркните. 2015целый/ символьный/ логический2.555логический с плавающей точкой / целыйTrueс плавающей точкой / символьный / логический2...
zayetsnataki
13.01.2023 03:51
Пример одномерного массива python ...
милана59
11.04.2021 14:28
Программирование циклов. Напиши код программы вычисления суммы чисел заданной последовательности чётных чисел от 1 до 50. Используй любой оператор цикла , буду очень благодарна)...
kozinasofia2006
30.09.2022 04:17
Проанализируйте фрагмент программы и запишите через запятую имя параметра начальные значения параметра конечно значения параметра величину изменения параметра...
nastyakot2609
12.12.2021 02:04
Определите значение a после выполнения программы....
Zavaw
31.08.2022 16:57
1. Определите значение переменной a после выполнения фрагмента программы: a = 10 b = 3 if a b: b += 12 else: a -= 7 if a b: a += 12 else: a -= 7 2. Переведите конструкцию языка. Какой...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses crt;
var fl1,fl2:text;
n,tmp:string;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
close(fl1);
tmp:=copy(n,length(n),1);
n:=tmp+n;
rewrite(fl2);
writeln(fl2,n);
close(fl2);
end.