В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ONO2017
ONO2017
11.06.2020 09:55 •  Информатика

Дано некоторое число составьте программу которая выводит какое это число положительное или отрицательное если оно положительное уменьшить в 2 раза а в другом случае взвести в квадрат.

Показать ответ
Ответ:
dennikitos
dennikitos
03.10.2020 08:06
//Pascal ABC.NET v3.1 сборка 1172

Var
 a:real;
begin
 readln(a);
 if a>0 then writeln('Положительное, ',a/2) else
  if a<0 then writeln('Отрицательное, ',sqr(a)) else
   writeln('0');
end.

Пример ввода:
-12
Пример вывода:
-, 144
0,0(0 оценок)
Ответ:
gagan1
gagan1
03.10.2020 08:06
По моему такая задача уже несколько раз была здесь.
//Pascal
var a:integer;
begin
  readln(a);
  if a>0 then writeln('Положительное ', a/2)
     else
         if a<0 then writeln('Отрицательное', a*a);
  if a=0 then writeln('0 - не положительное и не отрицательное число');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота