В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kofhagje46
kofhagje46
12.05.2023 20:22 •  Информатика

Дано трёхзначное число. Напишите программу на языке Паскаль, которые определяют: 1) является ли суммы его цифр двухзначным числом; 2) является ли произведение его цифр трехзначным числом; 3) больше ли это число произведение его цифр; 4) кратно ли пяти сумма его цифр; 5) кратно ли сумме его цифр на это число?

Показать ответ
Ответ:
EpoPanda
EpoPanda
21.01.2020 06:48

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int N;

   cin >> N;

   vector<int>negative;

   vector<int>positive;

   for (int i = 0; i < N; i++) {

       int A;

       cin >> A;

       if (A < 0)

           negative.push_back(A);

       else

           positive.push_back(A);

   }

       

   for (int i = 0; i < negative.size(); i++)

       cout<< negative[i]<<" ";

   for (int i = 0; i < positive.size(); i++)

       cout << positive[i] << " ";

}

0,0(0 оценок)
Ответ:
sashakoritnij
sashakoritnij
14.03.2022 16:12

#include <iostream>

using namespace std;

int main()

{

   int N, x, y;

   cin >> N >> x >> y;

   for (int i = x; i <= N; i += y)

   {

       cout << i << " ";

   }

}

Объяснение:

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()

{

   int N, x, y; // Объявление целочисленных переменных по условию

   cin >> N >> x >> y; // Ввод значений переменных с клавиатуры по условию

   for (int i = x; i <= N; i += y) // Начинаем с x, идем до N [включительно], с шагом в y

   {

       cout << i << " "; // Выводим значения через пробел

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота