В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
tibeck120
tibeck120
20.05.2020 17:05 •  Информатика

Даны 3 числа найти произведение тех из них которые по модулю меньше 1 написать программу на pascal

Показать ответ
Ответ:
shonchak
shonchak
09.10.2020 14:15

program Multi3;

var

 A: array [1..3] of Double;

 i: Integer;

 p: Double;

 b: Boolean;

begin

 Randomize;

 Write ('Исходные числа:');

 WriteLn;

 for i := 1 to 3 do begin

   A [i] := Random (4000) / 1000 - 1;  // заполняем числами, чтоб были и положительные и отрицательные

   Write (A[i] :10 :3, ' ');

 end;

 b := False;

 p := 1;

 for i := 1 to 3 do begin

   if Abs (A [i]) < 1 then begin

     b := True;    // включаем флаг, если найдено хотя бы одно подходящее число

     p := p * A [i];

   end;

 end;

 WriteLn;

 if b then

   WriteLn ('Произведение = ', p :10 :3)

 else

   WriteLn ('Произведение не определено.');

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота