В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
zejnabnasibova
zejnabnasibova
30.12.2021 20:03 •  Информатика

Даны 3 матрицы. Написать программу, которая высчитывает сумму и количество отрицательных элементов в каждой строке заданной матрицы порядка N*M. Ввод - процедура. Расчет - функция. вывод результата в основной программе с информатикой

Показать ответ
Ответ:
Victoriahamidul
Victoriahamidul
26.01.2023 12:31
Var
a, b, S, c, alpha, betta, gamma, H, P: real;
x, ar, br, gr: real;{alpha, beta. gamma в радианах}

begin
write('Введите длины двух сторон треугольника и площадь: ');
readln(a, b, S);
x := 2 * S / (a * b);
if x > 1 then writeln('Такой треугольник невозможен')
else
begin
gr := ArcSin(x);
c := Sqrt(Sqr(a) + Sqr(b) - 2 * a * b * Cos(gr));
P := a + b + c;
ar := ArcSin(a * Sin(gr) / c);
br := Pi - (ar + gr);
H := b * Sin(ar);
alpha := ar * 180 / Pi;
betta := br * 180 / Pi;
gamma := 180 - (alpha + betta);
writeln('Решение треугольника');
writeln('a=', a, ', b=', b, ', c=', c:0:5);
writeln('Alpha=', alpha:0:2, ', Betta=', betta:0:2, ', Gamma=', gamma:0:2);
writeln('P=', P:0:5, ', H=', H:0:5, ', S=', S)
end
end.

Тестовое решение:

Введите длины двух сторон треугольника и площадь: 3 4 6
Решение треугольника
a=3, b=4, c=5.00000
Alpha=36.87, Betta=53.13, Gamma=90.00
P=12.00000, H=2.40000, S=6
0,0(0 оценок)
Ответ:
raha12003
raha12003
03.03.2020 22:33

Программа предлагает исправить слово с ошибками, только при одном условии, если оно есть в словаре этой программы.

Проверка правописания знает не все слова в мире, а только те, которые ей ввел разработчик, поэтому некоторые слова программа исправить не сможет.

Зеленая - это синтаксическая ошибка допущена, не поставлена запятая и т.п.,

Красная - это орфографическая ошибка, то есть, ошибка в правописании.

Чтобы удалить один символ во всех словах, нужно нажать сочетание клавишь CTRL + F, если она не работает, то CTRL + H, тогда мы вводим символ, которых хотим найти, далее вводим в бланк "Заменить" пробел.

Чтобы удалить все лишние пробелы в документе замена двух пробелов подряд на один пробел (учтите, что в полях Найти и Заменить на пробелы вы не увидите). Процедуру повторить несколько раз. Это избавиться от нескольких пробелов между словами, но в начале строки останется один пробел.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота