В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Selima2005
Selima2005
21.11.2021 22:29 •  Информатика

Даны целые числа x и y. написать программу определения знака разности x-y. разность вычислять нельзя. разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y.

Показать ответ
Ответ:
жандос29
жандос29
03.07.2020 01:26
Program raznost_xy;
var x, y:integer;
begin
write ('Введите число х = ');
readln (x);
write ('Введите число у = ');
readln (y);

if (x>0) and (y>0) then
  begin
    if abs(x)>abs(y) then write ('x-y > 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y < 0');
  end;
      
if (x<0) and (y<0) then
  begin
    if abs(x)>abs(y) then write ('x-y < 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y > 0');
  end;

if (x=0) and (y=0) then write ('x-y = 0');
if (x>0) and (y<0) then write ('x-y > 0');
if (x<0) and (y>0) then write ('x-y < 0');
if (x=0) and (y>0) then write ('x-y < 0');
if (x=0) and (y<0) then write ('x-y > 0');
if (x>0) and (y=0) then write ('x-y > 0');
if (x<0) and (y=0) then write ('x-y < 0');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота