В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
viktorija0811
viktorija0811
25.09.2022 18:17 •  Информатика

Даны действительные числа a,b,c. составьте программу для вычесления max (a+b,c)-min (a+c,b).

Показать ответ
Ответ:
sofiahayda
sofiahayda
02.10.2020 21:00
// PascalABC.Net
function max(a,b:real):real;
begin
  if a>b then max:=a else max:=b
end;

function min(a,b:real):real;
begin
  if a<b then min:=a else min:=b
end;

var
  a,b,c:real;
begin
  Write('Введите три числа через пробел: '); Read(a,b,c);
  Writeln('Результат: ',max(a+b,c)-min(a+c,b))
end.

Тестовое решение:
Введите три числа через пробел: 5 -2 3.8
Результат: 5.8
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота