В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nastykaramova
Nastykaramova
23.04.2020 16:29 •  Информатика

Даны два целых числа a и b. напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b входные данные: в первой строке вводятся два целых числа a и b (a< =b, a,b не больше 100 по модулю) выходные данные: программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой) в c++

Показать ответ
Ответ:
ENGPrO
ENGPrO
31.08.2020 20:49
#include <iostream>

using namespace std;

int main()
{
    int a,b,n = 0;
    float S = 0;
    cin >> a;
    cin >> b;
    
    for(int i = a; i <= b; i++)
    {
         n++;
         S+=i*i;
    }
    S = S/n;
    cout.setf(ios::fixed);
    cout.precision(2);
    cout << "S = " << S << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота