В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nikto58
Nikto58
04.01.2023 13:35 •  Информатика

Даны натуральные числа k и n. составить программу формирования массива а, элементами которого являются числа, сумма цифр которых равна k и которые не больше n.
составить программу на паскале.

Показать ответ
Ответ:
снегурочка01
снегурочка01
05.08.2020 08:29

uses crt;

type arr=array[1..1000]of integer;

 

var N, K, C: integer;

a : arr;

 

function sum(n:integer):integer;

var s:integer;

begin

s:=0;

while n<>0 do

begin

 s:=s+n mod 10;

 n:=n div 10;

end;

sum:=s;

end;

 

procedure fill(var a:arr, C, N, K: integer);

var i:integer;

begin

c:=0;

for i:=1 to N do if sum(i)=k then

begin

 inc(c);

 a[c]:=i;

end;

end;

 

begin

clrscr;

write('N K-> ');

readln(N, K);

fill(a, c, N, K);

for i:=1 to с do write(a[i],' ');

readln;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота