Даны результаты успеваемости студента по варианту. написать программу на языке паскаль с требованиями:
возможность ввода успеваемости студента и стипендию (m=97 сомони) вручную.
вычисление среднего (s) и коэффициента повышения стипендии (k) по заданным правилам по варианту.
№ предмет
оценка
правила коэффициента
2. math()
5 econom()
7 informat(информатика)
4 eng()
2
если 4
c = 15 c = 2.00 c = 25 c = 9
c = 3 c = 1 c = 100 100
'qm' c = '' c = school2 error
Объяснение:
+ сложение(если строку str складывают с другой они просто скрепляются
// деление с выделением целой части
/ обычное деление чисел (происходит в формате float) даже если ответ целое число мы показывает десятые и сотые числа
% деление с выделением остатка
* умножение (если строка str умножается на целое число, то эта строка пишется несколько раз БЕЗ ПРОБЕЛА
** возведение в степень
max функция которая ищет максимум
строку на строку перемножать нельзя программа ложиться и выдаёт ошибку
Итак, целевой язык - C++. Это значит мы - радостные обладатели технологии потоков, с коей мы будем производить весь ввод/вывод как при работе с файлами, так и при работе со стандартным вводом/выводом (консолью).
Ну а раз уж мы работаем с потоками, то будем делать это красивенько: создадим класс-обёртку для потока ввода, цель которого - поиск в этом потоке цитат и отправка их на поток вывода (который мы передаём).
[!] Стоит отметить, что по заданию не сказано, что есть разница между ' и ". Поэтому будем считать их одинаковыми.
[!] Внимание! Рядом с исполняемым файлом надо создать текстовый файл data.txt c текстом и цитатами.
КодС++11
#include <iostream>#include <fstream>using std::cout;class QuotesFinder { std::istream &in_stream; bool is_it_in_quote = false;public: QuotesFinder() = delete; QuotesFinder(QuotesFinder&&) = default; QuotesFinder(QuotesFinder const&) = default; explicit QuotesFinder(std::istream &is) : in_stream(is) {} [[nodiscard]] bool eof() const { return in_stream.eof(); } // Вот тут происходит вся магия QuotesFinder& operator >> (std::ostream& out_stream) { char buffer; in_stream.get(buffer); //Получаем очередной символ из потока if (buffer == '\"' || buffer == '\'') { if (is_it_in_quote) { is_it_in_quote = false; out_stream << buffer; out_stream << "\n"; return *this; } is_it_in_quote = true; } if (is_it_in_quote) { out_stream << buffer; } return *this; }};int main() { std::ifstream file("data.txt"); // Открываем файл if (!file.is_open()) { cout << "File is not exits!"; return 1; } QuotesFinder finder(file); // Создаём обёртку из файлового потока while (!finder.eof()) // Пока не достигли конца потока finder >> cout; // переправляем очередной кусок информации в поток вывода}