В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
HwaSa77816
HwaSa77816
28.06.2022 02:38 •  Информатика

Даны три слова напечатать неповторяющиеся в них буквы. напишите программу в паскале .

Показать ответ
Ответ:
narek2006
narek2006
20.05.2022 17:27

# подключаем библиотеку, чтобы использовать случайные числа

from random import randint  

n=int(input('Введите количество элементов массива : '))# вводим размерность массива

a=[0]*n # Создаём массив размерность n

for i in range (0, n):  #в цикле  

 a[i]=randint(1,30)   # заполняем каждый элемент случайными числави

print(a)  #печатаем исходный массив

a=sorted(a)# сортируем исходный массив

print(a) # печатаем отсортированный массив

x=int(input('Введите Х :')) #вводим Х

for i in range (n-1, 1, -1): # в цикле

 if x > a[i]:                # ищем положение, куда вставить X

   a[n-1]=a[n-1]+a[i]   # к максимальному элементу массива прибавляем #элемент который заменили

   a[i]=x    # а на его место вставляем Х

   break

print(a) # печатаем ответ


Заполнить массив случайными числами и отсортировать его ввести число x. python желательно с коммента
0,0(0 оценок)
Ответ:
sofia308
sofia308
30.06.2022 19:10

Процесор вставляється в спеціальне місце – сокет (англ. socket – гніздо, розетка) на системній (материнській) платі, яка, у свою чергу, розміщується в системному блоці.

Для охолодження процесорів застосовують кулери — пристрої, які складаються з вентилятора і радіатора. На процесор встановлюють радіатор (зазвичай з алюмінію чи міді), а на нього — вентилятор, що забезпечує притік повітря до радіатора.

МАТЕРИНСЬКА ПЛАТА

Материнська, або системна, плата (від англ. motherboard) — це складна багатошарова друкована плата, до якої підключено практично всі пристрої комп’ютера. Друкована плата являє собою пластину з діелектрика, вкриту мережею мідних провідників-доріжок, якими електричні сигнали надходять до змонтованих на платі мікросхем та рознімів, куди вставляють інші пристрої комп’ютера.

На материнській платі розміщено центральний процесор та чіпсет (від англ. chip set) — набір мікросхем, спроектований для спільної роботи а метою виконання певних функцій. Оперативну пам’ять, відеокарту тощо вставляють у спеціальні розніми на материнській платі — слоти розширення.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота