В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Sofka11123
Sofka11123
13.01.2020 16:12 •  Информатика

Delphi. Числовой массив, состоящий из 20 элементов, формируется следующим образом: - первый элемент массива равен х, т.е a[1] = x;
- каждый след. член масива вычисляется по формуле a[i] = a[i-1]*i mod 100 +x.
Напишите программу, которая вычислит сумму элементов с индексами p, q и r в сформированном массиве.
В первой строке исходных данных записано одно целое число (-100≤ x ≤100).
Во второй строке заданы индексы p, q и r целые числа в диапазоне от 1 до 20.
Выведите одно число - суму элементов массивас индексами p, q и r.

Показать ответ
Ответ:
petr113
petr113
21.10.2022 23:32
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

type
  fs=(string,string);

begin
  var L:=new List<fs>;
  repeat
    var aw:=ReadlnString('>').ToWords;
    if aw.Length=0 then break;
    L.Add((aw[1],aw[0]))
  until false;
  var a:=L.OrderBy(t->t[0]);
  var i:=1;
  foreach var x in a do begin
    Writeln(i:4,' ',x[1],' ',x[0]);
    i+=1
    end
end.

Пример
> J.X. Smith
> B.A. Weiter
> A.C. Johnes
>
   1 A.C. Johnes
   2 J.X. Smith
   3 B.A. Weiter
0,0(0 оценок)
Ответ:
Murad11111111
Murad11111111
02.03.2023 03:54
Для корректной работы программы диапазоны не должны пересекаться, то есть, должно быть так: X1 ≤ X2 < Y1 ≤ Y2 < Z1 ≤ Z2

Var
   X1,X2,Y1,Y2,Z1,Z2,G:byte;
Begin
Write('X1 = ');ReadLn(X1);
Write('X2 = ');ReadLn(X2);
Write('Y1 = ');ReadLn(Y1);
Write('Y2 = ');ReadLn(Y2);
Write('Z1 = ');ReadLn(Z1);
Write('Z2 = ');ReadLn(Z2);
Write('G = ');ReadLn(G);
if (X1<=G)and(G<=X2) then WriteLn('Полутяжёлый вес')
else if (Y1<=G)and(G<=Y2) then WriteLn('Тяжёлый вес')
     else if (Z1<=G)and(G<=Z2) then WriteLn('Супертяжёлый вес')
          else WriteLn('Не попадает в данные весовые категории')
End.

Пример работы программы:

X1 = 85
X2 = 94
Y1 = 95
Y2 = 104
Z1 = 105
Z2 = 200
G = 115
Супертяжёлый вес
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота