В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
daria9303
daria9303
29.10.2022 10:32 •  Информатика

Dev_c++ напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

Показать ответ
Ответ:
sashka1281
sashka1281
28.07.2020 20:25
#include <iostream>                
#include <math.h>;               

using namespace std;               
int main(int argc, char* argv[])               
{               
    setlocale(LC_ALL, "Russian");
       double x1,x2,y1,y2,distance;             
 
        cout <<"Введите координату x1:";            
        cin>>x1;                    
        cout <<"Введите координату y1:";            
        cin>>y1;            
        cout <<"Введите координату x2:";            
        cin>>x2;            
        cout <<"Введите координату y2:";            
        cin>>y2;                             
        distance=sqrt(pow((x2-x1),2)+pow((y2-y1),2));      // формула для вычисления расстояния
        cout<<"Расстояние между двумя точками:"<<distance<<endl; 
        system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота