Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
532настя43510
08.08.2021 04:55 •
Информатика
Для двумерного массива целых чисел размерностью 5 на 5/ найти среднее значение положительных элементов массива
Показать ответ
Ответ:
Alina55332
08.10.2020 07:52
// PascalABC.NET 3.3
begin
var a:=MatrRandom(5,5,-10,10); a.Println(5);
writeln(a.ElementsByRow.Where(x->x>0).Average);
end.
Пример:
-3 2 -10 -5 -6
-1 0 4 -6 4
4 -4 3 -5 6
6 -10 4 2 -7
8 -6 9 -3 -1
4.72727272727273
0,0
(0 оценок)
Популярные вопросы: Информатика
ktvsl
14.03.2023 02:03
1) Даны длина стороны квадрата и радиус окружности. Определить площадь какой фигуры больше. 2) Известны две скорости: одна в м/с, другая в км/ч. Определить какая из скоростей меньше....
sisake
11.02.2021 09:44
Складіть блок схему алгоритму, у якому потрібно задумати два числа та визначити, яке з них більше або чи є вони рівними. Виконайте складений алгоритм для трьохпар чисел....
Нукку95
03.01.2023 20:39
не знаю как решать , хотяб примерно....
Msrisel
10.05.2022 19:46
Алфавит жителей планеты Железяка состоит из 512 символов. Какой информационный вес каждого символа? Информационное сообщение объемом 1Кбайт состоит из 1024 символов. Какова мощность...
LitunIlya
30.05.2023 19:19
Ребят выполнить первое задание (первое задание указано в картинке, картинка.png), надо сеть 10.19.0.0/16 разделить на подсети, в загруженном файле сделано второе задание. Буду очень...
прграмма45
11.01.2021 21:19
Сколько цифр в восьмеричной позиционной системе счисления?...
Виталина5413
12.02.2020 12:50
Метеорологическая станция ведёт наблюдения за влажностью воздуха. результатом одного измерения является целое число от 0 до 100 процентов, которое записывается цепочкой из нулей и...
kshevchenko631
11.12.2021 15:45
Артём он буратино пьеро мальвина и арлекин сбежали от каробаса барабана у них с собой было 3 монеты и 2 азбуки. почему у каждого был только один придёт. какой из придметов был у каждого,...
ppavlowich
10.04.2020 10:27
Спрашиваю тех, кто акибог в с++ недавно услышал про секретный тип данных, который вмещает примерно 10^36 подскажите, чо это за тип в инете облазил ничего не нашёл (там полная лажа)...
dima1tod
26.01.2021 22:16
есть 30 минут paskal abc напиши координаты...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
var a:=MatrRandom(5,5,-10,10); a.Println(5);
writeln(a.ElementsByRow.Where(x->x>0).Average);
end.
Пример:
-3 2 -10 -5 -6
-1 0 4 -6 4
4 -4 3 -5 6
6 -10 4 2 -7
8 -6 9 -3 -1
4.72727272727273