Двумерные массивы (в питоне ) Задан двумерный массив Y из 5-и строк и 5-и столбцов. Составить программу подсчёта суммы всех положительных элементов и суммы элементов по главной диагонали.
В бутылке минеральная вода. Сейчас стакан не стоит между чаем и молоком. Поставить стакан между бутылкой с минеральной водой и кружкой нельзя, так как тогда он будет стоять между минеральной водой, а должен стоять рядом с чаем и молоком. Значит, стакан можно поставить между кружкой и чашкой. Стакан оказывается в середине, значит, в нем кофе. Молоко не может быть в кружке, так как по соседству с молоком будет кофе и минеральная вода, а рядом с молоком должен быть квас. Значит, молоко в чашке. Так как по соседству с молоком должен быть квас, то в кувшине квас. ответ: в бутылке минеральная вода, в кружке чай, в чашке молоко, в стакане кофе, в кувшине квас.
Var strok: string; n,k: integer; begin writeln('введите строку'); readln(strok); writeln('с какого по счёту символа начать удаление?'); readln(n); writeln('сколько символов удалить?'); readln(k); delete(strok, n, k); writeln(strok); end. это первая var strok,strok2: string; n: integer; begin writeln('введите строку'); readln(strok); writeln('с какого символа по счёту вставить строку?'); readln(n); writeln('какую строку вставить?'); readln(strok2); insert(strok2 ,strok, n); writeln(strok); end. это вторая, а третья в коментах, иначе не влезет
ответ: в бутылке минеральная вода, в кружке чай, в чашке молоко, в стакане кофе, в кувшине квас.
begin
writeln('введите строку');
readln(strok);
writeln('с какого по счёту символа начать удаление?');
readln(n);
writeln('сколько символов удалить?');
readln(k);
delete(strok, n, k);
writeln(strok);
end.
это первая
var strok,strok2: string;
n: integer;
begin
writeln('введите строку');
readln(strok);
writeln('с какого символа по счёту вставить строку?');
readln(n);
writeln('какую строку вставить?');
readln(strok2);
insert(strok2 ,strok, n);
writeln(strok);
end.
это вторая, а третья в коментах, иначе не влезет