В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nikitakozlav8niks
nikitakozlav8niks
17.02.2020 11:32 •  Информатика

ЭТО НАДО СДЕЛАТЬ С ПРОГРАММЫ Python! Заранее Создать игру «Камень-ножницы-бумага» .Задачи: камень, ножницы, бумага - популярная игра руками, известная во многих странах. Часто используется для жеребьевки. Напишите программу, которая определяет пере-лем в игре компьютера и человека. Схему определения победителя приведены на рис. 26.6.1) Откройте окно IDLE и соз-рить новое окно программы. В начале программы написанными шить комментарии - правила игры. # Камень ломает ножницы # Ножницы режут бумагу # Бумага накрывает каминь2) Загрузить функцию randint, необходимую для получения вы- случайного цифр: from random import randintЗначення для выбора хра-Тимей в списке: choice = [ 'камень', 'ножницы', 'бумагу'] Рис. 26.6Програма приглашает к игре с оператора:

Показать ответ
Ответ:
barbara27
barbara27
25.02.2023 17:30
//Pascal ABC.NET v3.1 сборка 1172

Var
 f,s:text;
 st,sp:string;
 i:integer;
 c:char;
begin
 assign(s,'text1.txt');
 reset(s);
 while not Eof(s) do
 begin;
 readln(s,sp);
 st:=st+sp+chr(10)+chr(13);
 end;
 close(s);
 for i:=1 to length(st) div 2 do
  begin
   c:=st[i];
   st[i]:=st[length(st)-i+1];
   st[length(st)-i+1]:=c;
  end;
 assign(f,'text.txt');
 rewrite(f);
 write(f,st);
 close(f);
end.

Текст в файле text1.txt:

Simple text
1And another simple text
2New text

Текст в файле text.txt:
txet weN2
txet elpmis rehtona dnA1
txet elpmiS
0,0(0 оценок)
Ответ:
ilonarudneva14Sofass
ilonarudneva14Sofass
11.03.2020 12:23
Если вынуть 94 конфет, то будут конфеты всех 3 видов.Пусть у нас по n конфет каждого вида.Тогда может так получиться, что мы вынем 2n конфет, и они будут только 2 видов. И только, вынув (2n+1)-ю конфету, мы получим все три.2n+1 = 942n = 93.Значит, конфет одного и другого вида по [93/2] = 46,а конфет третьего вида 47.Пусть ирисок и леденцов по 46, а шоколадных 47.Вынув 46 ирисок и 46 леденцов (92 конфет), мы получим 2 вида.Вынув 46 ирисок и 47 шоколадных (93), мы получим 2 вида.Вынув 46 леденцов и 47 шоколадных (93), мы получим 2 вида.И только вынув 94-ую (в 1 случае 93 и 94), мы получим 3 вида.ответ: всего конфет было 46 + 46 + 47 = 139.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота