ЭТО СОР Задача: рассчитать площадь многоугольника S= В+ Г/2 -1 Составите код программы. (Язык программирования Phyton)
2. Опишите модель решения поставленной задачи.
a) Входные данные программы
b) Выходные данные программы
c) Цель проектирования программы
d) Назначение программы
e) Область применения программы
3. Укажите название, тип данных, а также строку программного кода, обеспечивающую проверку корректности отображения переменной, описывающей входные данные (один на выбор).
a) Наименование.
b) Тип данных.
c) Программный код для проверки корректности отображения.
4. Заполните ячейки трассировочной таблицы, используя данные из проекта
procedure Convert(V:array of integer);
begin
for var i:=0 to V.Length-1 do
if V[i]>9 then V[i]:=9
else
if V[i]<5 then V[i]:=5
end;
procedure Develop(c:char; k:integer);
begin
WritelnFormat('*** Массив {0} ***',c);
var a:=ArrRandom(k,-5,15);
Write('исходный : '); a.PrintLn(',');
Convert(a);
Write('результат: '); a.PrintLn(',');
end;
begin
var m:=ReadInteger('Количество элементов в массиве A:');
var n:=ReadInteger('Количество элементов в массиве B:');
Develop('A',m);
Develop('B',n)
end.
Тестовое решение:
Количество элементов в массиве A: 15
Количество элементов в массиве B: 10
*** Массив A ***
исходный : 6,5,-5,9,1,0,-3,9,13,12,-4,8,11,14,-5
результат: 6,5,5,9,5,5,5,9,9,9,5,8,9,9,5
*** Массив B ***
исходный : 5,12,12,4,7,9,7,-3,-1,-2
результат: 5,9,9,5,7,9,7,5,5,5
#include<iostream>
#include<cmath>
void main() {
char ch1, ch2;
int vol1, vol2;
std::cin >> ch1 >> vol1;
std::cin >> ch2 >> vol2;
if abs(ch1 - ch2) <= 2) && (abs(vol1 - vol2) <= 2)) && ((ch1 != ch2) && (vol1 != vol2))) && !((abs(ch1 - ch2)==1) && (abs(vol1-vol2))==1)) std::cout << "Possible";
else
std::cout << "Impossible";
}
3)
#include<iostream>
using namespace std;
void main() {
int n,m;
cin >> n,m;
cout<<n;
for(int i=n;i<=m;i++)
cout<<i+2;
}
4)
#include <iostream>
using namespace std; void main(){
int mass[2][4] //размерность своего массива вписывай.
{
{ 1, 2, 3, 4 }, //вписывай свои числа.
{ 1, 2, 3, 4 }
};
for (int i=0 ; i<2;++i)
{
for (int j=0 ; j<4;++j)
{
if(mass[i][j]<0)
cout<<mass[i][j];
}
}
system("pause");
}