В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
uma12
uma12
15.01.2021 18:19 •  Информатика

Генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел.составьте программу, с которой напечатайте на одной строчке исходный массив, а на следующей строке - сумму квадратов элементов с начетными индексами.

Показать ответ
Ответ:
kolitka1
kolitka1
07.07.2020 08:27


тебе как надо решать есть


0,0(0 оценок)
Ответ:
catpolina21
catpolina21
07.07.2020 08:27
Const  n = 20;
var  a :array [1..n] of integer;  i, sum :integer;
begin
  randomize;  for i:= 1 to n do    a[i]:= random(100);  for i:= 1 to n do    write(a[i],' ');  writeln;      sum:= 0;  for i:= 1 to n do    if i mod 2 = 1 then      sum:= sum + sqr(a[i]);  writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота