ХЕЛП (PascalABC) в классе 22 учащихся. каждый день по разным причинам в классе может отсутствовать от 0 до 5 учащихся. В массиве хранится информация о ежедневном кол-ве присутствующих учеников в течение 30 учебных дней. Составьте программу, определяющую, сколько раз за этот период времени класс присутствовал на уроках в полном составе
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Количество строк/столбцов в матрице:');
Writeln('*** Исходная матрица ***');
var a:=MatrRandom(n,n,1,50);
a.Println(3); Writeln(3*a.ColCount*'-');
// начало расчетов
var s:=0;
for var i:=0 to n-1 do s+=a[i,n-i-1];
Writeln('1: S=',s);
Write('2: Суммы построчно: '); a.Rows.Select(row->row.Sum).PrintLn;
Write('3: Произведение элементов: ');
a.ElementsByRow.Aggregate(BigInteger(1),(p,q)->p*q).PrintLn;
var p:BigInteger:=1;
for var i:=0 to n-1 do p*=a[i,i];
Writeln('4: П=',p);
end.