В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Амина9505
Амина9505
06.07.2021 09:06 •  Информатика

ХЕЛП

ПАСКАЛЬ . Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Показать ответ
Ответ:
Прша
Прша
21.01.2022 06:46

//1

#include <iostream>

using namespace std;

signed main() {

int N, pr = 1;

cin >> N;

N = abs(N);

if ((N % 10 * (N / 10) % 10 * N / 100) > 10 and (N % 10 * (N / 10) % 10 * N / 100) < 100)

 cout << "YES";

else

 cout << "NO";

return 0;

}

//2

#include <iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int N;

cin >> N;

N = abs(N);

while (N > 0) {

 if ((N % 10) % 2 == 0)

  cout << N % 10 << " - четное\n";

 else

  cout << N % 10 << " - нечетное\n";

 N /= 10;

}

return 0;

}

//3

#include <iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int a, b;

cin >> a >> b;

if (a % b == 0)

 cout << "Число " << a << " делится без остатка на число " << b;

else

 cout << "Число " << a << " не делится без остатка на число " << b;

return 0;

}

0,0(0 оценок)
Ответ:
лаьтслчлвт
лаьтслчлвт
12.05.2021 03:44

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   setlocale(LC_ALL, "RU");

   int N;

   cin >> N;//массив на N элементов

   vector<int>a;

   for (int i = 0; i < N; i++)

       a.push_back(rand()%100);// заполнение массива числами от 0 до 100

   for (int i = 0; i < N; i++)

       cout << a[i] << " ";

   cout << endl;

   bool flag=false;

   int number;

   for (int i = 0; i < N; i++) {

       auto r = find(a.begin(), a.end(),a[i]);// функция стандартной библиотеки для поиска

       if (r != a.end()&&r-a.begin()!=i)

       {

           number = r - a.begin();// номер элемента массива с одинаковым значением

           flag = true;

           break;

       }

   }

   if (flag)

       cout <<"В массиве присутствуют элементы с одинаковыми значениями. Одним из равных значений является: "<<a[number];

   else

       cout << "В массиве не присутствуют элементы с одинаковыми значениями";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота