В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
anel1985
anel1985
01.07.2022 00:00 •  Информатика

Хелп! Задано натуральное число n. Написать программу вычисления суммы натуральных чисел от 1 до n.

i=1..n, S=0,
S=S+i

Показать ответ
Ответ:
inara12345
inara12345
25.03.2021 20:59

1. смешанная адресация

2. то же значение, что в В2

3. =B4*($C$2+D3)

4. ошибка, С$5 выйдет за пределы таблицы

5. =$D6+E6

Объяснение:

1. один знак $ - смешанная, нет знаков $ - относительная, два знака $ - абсолютная

2. то же значение, что в B2, т.к. абсолютная адресация

3. у ячеек с относительной адресацией увеличился номер строки на 1

4. ошибка связана с тем, что формула копируется в ячейку, находящуюся на 3 столбца левее, а столбец С в ссылке С$5 может быть изменен максимум до столбца А, то есть на 2 левее

5. столбец D не изменяется т.к. слева $, а остальные значения будут меняться при копировании

0,0(0 оценок)
Ответ:
ochensad
ochensad
10.04.2021 18:25

#include <iostream>

using namespace std;

int main()

{

   int mas[20] = {};

   int even = 0;

   int odd = 0;

   for (int i = 0; i < 20; i++)

   {

       cin >> mas[i];

   }

   for (int i = 0; i < 20; i++)

   {

       if (mas[i] % 2 == 0)

       {

           even++;

       }

       else

       {

           odd++;

       }

   }

   if (even > odd)

   {

       cout << "Чётных больше.";

   }

   else if (odd > even)

   {

       cout << "Нечётных больше.";

   }

   else

   {

       cout << "Равное количество.";

   }

}

Объяснение:

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()

{

   int mas[20] = {}; // Создание целочисленного массива размерностью 20, заполненного нулями

   int even = 0; // Создание целочисленной переменной, хранящей количество четных элементов

   int odd = 0; // Создание целочисленной переменной, хранящей количество нечетных элементов

   for (int i = 0; i < 20; i++) // Идём по массиву

   {

       cin >> mas[i]; // Вводим элементы массива с клавиатуры

   }

   for (int i = 0; i < 20; i++) // Идём по массиву

   {

       if (mas[i] % 2 == 0) // Если остаток от деления значения массива mas с индексом i на 2 = 0

       {

           even++; // +1 к четному

       }

       else // Иначе

       {

           odd++; // +1 к нечетному

       }

   }

   if (even > odd) // Если значение переменной even > значения переменной odd

   {

       cout << "Чётных больше."; // Выводим ответ

   }

   else if (odd > even) // Если значение переменной odd > значения переменной even

   {

       cout << "Нечётных больше."; // Выводим ответ

   }

   else // Иначе

   {

       cout << "Равное количество."; // Выводим ответ

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота