В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tytyuuh88
tytyuuh88
07.05.2023 11:10 •  Информатика

Https://www.online-python.com/ Напишите программу, которая вoзвращает рeзультат цeлочисленного и по модулю дeления любого цeлого числa нa -17.

Показать ответ
Ответ:
Lop1234kop
Lop1234kop
19.05.2022 04:09
Uses crt;
var f:text;
    i,x,sm,n:integer;
    pr:longint;
begin
randomize;
clrscr;
pr:=1;
assign(f,'f.txt'); rewrite(f);
writeln('Введите число заполнений (например 6, в файле будет шесть натуральных чисел) ?'); readln(n);
for i:=1 to n do
begin
write(i,') ');
readln(x);
writeln(f,x);
end;
close(f);
reset(f);
while not Eof(f) do
begin
read(f,x);
sm:=sm+x;
if x <> 0 then pr:=pr*x;
end;
if n <> 0then
begin
writeln;
writeln('Сумма всех чисел = ',sm);
writeln('Произведение всех чисел = ',pr);
end else writeln('Файл пустой.');
readkey;
close(f);end.
0,0(0 оценок)
Ответ:
edakovagfffgg
edakovagfffgg
19.05.2022 04:09
Cvar
  f: Text;
  k: integer;
  s, p: longint;
  i: integer;

begin
  Assign(f, 'output.dat');
  Rewrite(f);
  writeln('Вводите данные, окончание число 7777');
  repeat
    read(k);
    if k<>7777 then writeln(f,k)
    until k=7777;
  Close(f);
  Reset(f);
  s := 0;
  p := 1;
  writeln;
  while not Eof(f) do
  begin
    readln(f, k);
    write(k:4);
    s := s + k;
    if k <> 0 then p := p * k
  end;
  Close(f);
  writeln;
  writeln('Сумма= ', s, ', произведение= ', p)
end.

Вводите данные, окончание число 7777
3
6
-4
6
2
-3
-4
2
6
0
5
-1
7777

   3   6  -4   6   2  -3  -4   2   6   0   5  -1
Сумма= 18, произведение= 622080
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота