В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
SLT1337
SLT1337
16.08.2020 09:50 •  Информатика

И. напишите программу на pascale, которая по введённым координатам точки на плоскости (x,y) определяет, принадлежит точка заштрихованной фигуре или нет

Показать ответ
Ответ:
KarinaCorso
KarinaCorso
12.05.2020 23:36
Так как в задании не указано, что введенное слово должно обрамляться пробелами, то код может быть такой:

var s,a:string;
    begin
    write('Введите строку : ');
    readln(s);
    write('Введите слово : ');
    readln(a);
       if(pos(a, s) <> 0) then writeln('Слово "',a,'" в строке есть')
       else writeln('В строке такого слова нет');
    end.

Тест №1
Введите строку : Привет участникам олимпиады!
Введите слово : ник
Слово "ник" в строке есть

Тест №2
Введите строку : Всем привет!
Введите слово : админ
В строке такого слова нет
0,0(0 оценок)
Ответ:
mynomynou
mynomynou
04.01.2020 06:01

#include <iostream>

int main() {

const int SIZE = 10;

bool isSence = false;

int sum = 0;

int count = 0;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 arr[i] = rand() % 20 - 10; // "рандомно" заполняем массив от -10 до 10

 std::cout << arr[i] << "\t"; // выводим массив в консоль

 if (arr[i] >= 0)

  isSence = true;

}

for (int i = 0; i < SIZE; i++)

{

 if ((isSence) && (arr[i] > 0))

  sum += arr[i]; //sum = sum + arr[i];

  count++;

}

if (isSence)

 std::cout << "\nсреднее арифметическое положительных чисел = " << double(sum) / count << std::endl; // явное приведение типов

else

 std::cout << "\nВ массиве нету положительных чисел или нету нулей и/или отрицательных чисел" << std::endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота