В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Sold5561
Sold5561
26.02.2023 06:30 •  Информатика

Идет i-ая секунда суток. напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с с начала суток. например: 13257 секунд = 3 часа 40 минут и 57 секунд. выведите на экран фразу: «с начала суток часов, ….. минут и …. секунд». вместо многоточий вывести значения переменных.

Показать ответ
Ответ:
Sveta7102006
Sveta7102006
02.10.2020 08:36
Var
  i, h, m, s: integer;

begin
  Write('Введите количество секунд от начала суток: ');
  Readln(i);
  h := i div 3600;
  m := i mod 3600;
  s := m mod 60;
  m := m div 60;
  Writeln('С начала суток часов, ', m, ' минут ', s, ' cекунд')
end.

Тестовое решение:
Введите количество секунд от начала суток: 13257
С начала суток часов, 40 минут 57 cекунд
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота