В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Игра в числа ведётся на одномерном массиве целых положительных чисел. Перед началом, жеребьёвкой определяется, кто будет ходить первым (первый игрок), а кто – вторым (второй игрок). Процесс игры состоит в том, что игроки по очереди (сначала первый игрок, затем второй, следом опять первый и так далее) вычёркивают числа из массива. Вычеркнуть можно только число, находящееся в конце или начале оставшегося массива. При этом всегда вычёркивается максимальное число из этих двух. Если первое и последнее числа массива равны, то вычёркивается первое. Игра продолжается до того момента, пока не будут вычеркнуты все числа. Каждое вычеркнутое число идёт в актив тому, который его вычеркнул. После окончания игры каждый игрок суммирует вычеркнутые им числа. Победителем объявляется тот, кто наберет больше очков. Некоторые игроки поняли, что результат не зависит от стратегии игры, и решили попросить Вас написать программу для получения результата.

В первой строке вводится одно целое число N – количество чисел в массиве (1 ≤ N ≤ 104). Во второй строке находятся N целых положительных чисел из диапазона [1, 32000], разделённых пробелом.

Выведите два числа, разделенные двоеточием. Первое число – количество очков, набираемых первым игроком при игре на этом массиве, второе число – для второго.Решение на паскале.

Показать ответ
Ответ:
13081990
13081990
17.04.2021 05:23

использовать Рисователь

алг кот

нач

новый лист(160, 210, белый)

линия (35,10,20,20)

линия (10,100,20,20)

линия (10,100,20,140)

линия (50,200,20,140)

линия (50,200,90,200)

линия (80,180,90,200)

линия (80,180,100,180)

линия (110,200,100,180)

линия (110,200,150,200)

линия (130,180,150,200)

линия (130,180,150,150)

линия (130,115,150,150)

линия (130,115,150,80)

линия (35,10,50,25)

линия (50,25,40,140)

линия (50,25,40,140)

линия (40,140,55,150)

линия (55,150,120,150)

линия (120,150,120,120)

линия (120,120,90,120)

линия (90,120,50,100)

линия (50,100,80,90)

линия (80,90,110,30)

линия (110,30,110,10)

линия (110,10,150,80)

кон

0,0(0 оценок)
Ответ:
FireGame228
FireGame228
26.07.2022 14:26

Не, не получится накопить

Объяснение:

program kopilka;

uses crt;

var x, c, p, y:real; i, m:integer;

begin

clrscr;

write ('Введите начальную сумму вклада, рублей: ') ;

readln(x);

write ('Введите желаемую сумму накопления, рублей: ') ;

readln(c);

write ('Введите срок накопления, лет: ') ;

readln(y);

m:=round(y*12);

write ('Введите ежемесячно начисляемый процент (%) : ') ;

readln(p); p:=p/100;

for i:=1 to m do

x:=x+x*p;

if x<c then write('Вы накопили ',x:6:2,' рублей, это меньше запланнированной суммы в ',c:6:2,' рублей')

else write('Ваша цель по накоплению ',c:6:2,' рублей достигнута: вы накопили ',x:6:2,' рублей') ;

readln;

end.


Код в паскаль ! Человек вложил 100 000 рублей под 4% в месяц. Успеет ли он накопить на машину стоимо
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота