В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Yana18102001
Yana18102001
14.09.2020 23:17 •  Информатика

Имеется массив, содержащий упорядоченную последовательность целых чисел. Необходимо в него включить числа (с клавиатуры), не нарушив упорядоченности. Написать программу на C++

Показать ответ
Ответ:
dsokaof12lisalislais
dsokaof12lisalislais
30.04.2022 19:19
1. var a: array[1..100] of Integer ;
i,n,p: integer;
begin
p:=1;
Writeln('Введите количество элементов в массиве');
Readln(n);
Writeln('Масив');
for i:=1 to n do
begin
a[i]:=Random(10);
Write(a[i]:3);
if a[i] mod 2 = 0 then p:=p*a[i];
end;
Writeln;
Writeln('Произведение четных элементов массива = ', p);
end.

2. var a: array[1..10] of Integer ;
i,c,sum,n: integer;
begin
Writeln('Введите число');
Readln(c);
for i:=1 to 10 do
begin
Writeln('Введите ', i,' элемент массива');
readln(a[i]);
if a[i] > c then
begin
sum:=sum+a[i];
n:=n+1;
end;
end;
Writeln('Среднее арифмитическое элементов массива которые превышают ', c, ' = ',sum/n);
end.
0,0(0 оценок)
Ответ:
Igor599
Igor599
24.08.2021 19:21
В этой проге 1 и 2
program p1;
uses crt; Const n = 10;
var a:array [1..n] of integer;
i,p,c:integer;
k,sr:real;
begin
read(c);
 for i := 1 to N do begin
 a[i]:= random(21)-10;
 write(a[i]:4);
 end;
 writeln;
 p:=1;
 sr:=1;
  for i:=1 to N do begin
   If (a[i]mod 2 = 0) and (a[i]<>0) then begin
    p:=p*a[i];
    end;
    If c<=a[i] then begin
    sr:=a[i]*sr;
    K:=k+1;
    end;
   
    end;
    sr:=sr/k;
   writeln('Произведение чётных :',p);
   writeln('Среднее арифметическое ',sr:5:2);

end.
Только всё равно проверь!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота