В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
jena6
jena6
04.11.2021 14:02 •  Информатика

Индивидуальная работа
Учитель дает задание написать программу для вывода изображения:
Установить размер экрана 800, 600
Задний фон закрасить определенным цветом (цвет можно выбрать любой), поэкспериментируйте с цветами
Добавить на рабочую поверхность экрана космический корабль, файл shuttle.png
Установить на задний фон изображение Сатурна, файл saturn.jpg
Сохранить написанную программу

Показать ответ
Ответ:
WhataMataFon
WhataMataFon
16.08.2022 00:04

Pascal ABC.

1. Код с предусловием:

var

  a, b, n, s: integer;

begin

    readln(a, b);

    s := 1;

    n := 0;

    while a <= b do begin

          if a mod 2 = 0 then begin

             s := s * a;

             inc(n);

          end;

          inc(a);

    end;

    writeln( exp(ln(s)*(1/n))  );

end.

2. Код с постусловием:

var

  a, b, n, s: integer;

begin

    readln(a, b);

    s := 1;

    n := 0;

    repeat

          if a mod 2 = 0 then begin

             s := s * a;

             inc(n);

          end;

          inc(a);

    until a > b;

    writeln( exp(ln(s)*(1/n))  );

end.

0,0(0 оценок)
Ответ:
Khmelnitskaya
Khmelnitskaya
05.11.2021 08:55

Реестр и перегруженный диск

Вторая причина торможения компьютера - это конечно же замусоренный реестр и перегруженный системный диск. Если у Вас в реестре Windows много различных записей из-за того, что Вы постоянно устанавливаете и удаляете различные программы, то это также может стать причиной торможения компьютера. Нужно знать, как правильно почистить компьютер, чтобы он не тормозил и не глючил. И начнём мы с реестра.

Чтобы почистить реестр рекомендую использовать простую программу CCleaner. Скачайте, установите и запустите её.

Перейдите в раздел Реестр, убедитесь что здесь стоят все галочки, и нажмите Поиск проблем.

Поиск ошибок в реестре Виндовс

Программа найдёт весь ненужный хлам в реестре и предложит его Очистить. Нажимаем кнопку Исправить и исправляем.

Исправление ошибок в реестре

Повторяем эту процедуру, до тех пор, пока в реестре не будет найдено минимальное количество проблем.

Также нам нужно почистить диск С. Заходим в раздел Компьютер, нажимаем правой кнопкой мыши по системному разделу и выбираем пункт Свойства.

Свойства системного диска

Здесь находим кнопку Очистка диска, и ждём пока программа проанализирует данные и предложит удалить ненужный хлам.

Очистка системного диска

Поиск ненужных файлов

После анализа нам нужно поставить галочки напротив всех пунктов и нажать Ок и Удалить файлы.

Удаление ненужных файлов

Удалить файлы в Очистке диска

А ещё не забудьте очистить папки TEMP. Это временные папки, файлы в которых вообще не нужны.

Заходим в раздел Компьютер - Диск (C:) - Папка Windows - Папка TEMP. То, что внутри, это ненужные файлы, выделяем и удаляем.

Папка TEMP

Также нужно очистить вторую папку ТЕМП. Для этого нажимаем на клавиатуре Win+R, вводим команду %TEMP% и нажимаем Ок.

Команда Выполнить

У нас открывается вторая папка TEMP, эти файлы тоже не нужны. Выделяем их все и Удаляем.

Вторая папка TEMP

Итак второй мы тоже разобрали. Обязательно чистим реестр от хлама и диск от ненужного мусора. Это очень важно!

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота