В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Наталья0101
Наталья0101
09.11.2021 01:03 •  Информатика

Информатика. 1)написать программу, которая запрашивает одно число-количество учащихся в классе, и выводит минимальное количество парт, необходимое для рассадки по 2 человека. 2)написать программу, которая запрашивает одно натуральное пятизначное число, и выводит его третью цифру. 3)для покраски стен и пола комнаты шириной а метров, длинной b метров и высотой с метров(а,b и с-целые числа) необходимое закупить краску. известно, что одной банки крачки хватает на покраску k кв.метров поверхности.найти минимальное необходимое количество банок краски. прогорамма должна получать на выход четыре числа-ширина, высота, длина и количество кв.метров, на которое хватает одной банки краски, и выводит необходимое количество банок.

Показать ответ
Ответ:
trukit
trukit
05.10.2020 08:16
{1}
var
n : longint;
begin
readln (n);
write ( (n div 2) + (n mod 2));
end.

{2}
var
n : longint;
begin
repeat
readln (n);
until (n in [10000..100000]) and (abs(n) = n);
write ( ((n mod 1000) - (n mod 100)) div 100 );
end.

{3}
var
a, b, c, sqrM, sum : longint;
begin
readln (a, b, c, sqrM);
sum:=(((a+b)*c)*2 + a*b) div sqrM;
if a+b)*c)*2 + a*b) mod sqrM)<>0 then inc(sum);
write (sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота