В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Aleksa5432
Aleksa5432
18.10.2021 13:45 •  Информатика

Информатика 9 класс 50 написать программу в abcпаскаль которая вычислит сумму цифр пятизначного числа и определит находится ли эта сумма в диапазоне от 20 до 25 включительно(< = или > =)

Показать ответ
Ответ:
oksanalap1
oksanalap1
02.08.2020 12:56
Var
  i, c: int64;
  s: string;
 begin
  readln(s);
  if(s.Length = 5) then
begin
    for i := 1 to 5 do
      c := c + strtoint(s[i]);
    writeln(c);
    if(c >= 20) and (c <= 25) then write('Находится')
    else write('Не находится');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота