В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Anastasii03
Anastasii03
07.11.2021 22:07 •  Информатика

Информатика 9 класс, Паскаль. Надо составить программу. Фотографии предоставлена ниже.


Информатика 9 класс, Паскаль. Надо составить программу. Фотографии предоставлена ниже.

Показать ответ
Ответ:
Someoneone
Someoneone
29.09.2021 04:09
Var a, b: integer;
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА 
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.
0,0(0 оценок)
Ответ:
yuliana080704
yuliana080704
30.08.2020 01:02
Не самый рациональный метод решения, но как говорится чем смог тем

var a,b,c,x,kc,kn,k1,k2:integer; 
begin 
kc:=1; 
kn:=1; 
k1:=0; 
k2:=0; 
a:=0; 
b:=0; 
writeln('Введите число x'); 
read(x); 
while x>0 do begin 
c:=x mod 10; 
if c mod 2=0 then begin 
inc(k1); 
a:=a+c*kc; 
kc:=kc*10; 
end; 
if c mod 2<>0 then begin 
inc(k2); 
b:=b+c*kn; 
kn:=kn*10; 
end; 
x:=x div 10; 
end; 
if k1>k2 then writeln('Четных больше нечетных') else if k1=k2 then writeln('Количество четных = количеству нечетных') else writeln('Четных меньше нечетных'); 
writeln(a,' ', b); 
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота