В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Annetaolk963
Annetaolk963
30.09.2021 19:13 •  Информатика

ИНФОРМАТИКА 9 КЛАСС

Работа с системой программирования на языке Паскаль

Напишите программу для реализации следующего сценария:
• целочисленный массив заполняется случайными числами (размерность
массива и числовой диапазон определите самостоятельно);
• выводится сообщение «Заполненный массив»;
• с новой строки выводятся элементы массива в строку через пробел;
• выводится сообщение «Введите значение числа К»;
• запрашивается ввод с клавиатуры целочисленного значения числа К;
• выводится сообщение «Элементы массива, кратные К»;
• осуществляется поиск в массиве элементов, кратных числу К;
• выводятся элементы массива, кратные числу К.

Показать ответ
Ответ:
akirienko2003
akirienko2003
12.10.2020 19:44

ответ: Программа рабочая, проверена.

Program zadacha;

var  

 a: array [1..50] of integer; // размерность массива = 50

 i,k: integer;

begin

begin

 for i:=1 to 50 do

   a[i] := Random(100); // числа от 0 до 100 будут присутствовать в массиве

 writeln('Заполненный массив: ');

 for i:=1 to 50 do

   write(a[i],' '); end; // выводим массив на экран до проверки

writeln; //новая строка

writeln('Введите значение числа K: '); readln(k);

writeln('Элементы массива, кратные K:');

for i:=1 to 50 do

if (a[i] mod k = 0) then write(a[i],' ');  

end.

Объяснение:

i - порядковый номер элемента

a - сам массив

k - вводимое число

В остальном оставила комментарии.

Размерность массива и его диапазон указан в программе числами, т.к. в задаче не было вопроса о вводе элементов или вводе размерности.


ИНФОРМАТИКА 9 КЛАСС Работа с системой программирования на языке Паскаль Напишите программу для реа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота