В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ReutovTema222
ReutovTema222
06.06.2021 13:35 •  Информатика

Информатика 9, с , завтра на pascalabc.netлабораторная работа 8учимся программировать с массивамина фото указаны 3 примера, , их решить

Показать ответ
Ответ:
ирина1546
ирина1546
03.07.2020 03:17

1 Тема) Когда появились первые боевые роботы?

В 1910 году, вдохновлённый успехами братьев Райт, молодой американский военный инженер из Огайо Чарльз Кеттеринг предложил использовать летательные аппараты без человека. По его замыслу управляемое часовым механизмом устройство в заданном месте должно было сбрасывать крылья и падать как бомба на врага. Получив финансирование армии США, он построил, и с переменным успехом испытал несколько устройств, получивших названия The Kattering Aerial Torpedo, Kettering Bug (или просто Bug), но в боевых действиях они так и не применялись.

Объяснение:

Как то так

0,0(0 оценок)
Ответ:
rran
rran
20.02.2022 04:17

Программа:

Pascal:

var

 arr: array of integer;

 n, i, sum: integer;

begin

 write('Количество учеников: '); readln(n);

 SetLength(arr, n);

 

 for i := 0 to n - 1 do begin

   arr[i] := random(2, 5);

   sum += arr[i];

 end;

 writeln('Оценки учеников в классе: ', arr);

 writeln('Средняя оценка: ', sum/n);

end.

Для начала выделяем память массиву целых чисел, после - регистрируем переменные, которые будем использовать далее. Запрашиваем кол-во учеников (это и будет размерностью массива), устанавливаем длину массива - введённое число n. Циклом проходима по элементам массива, устанавливаем рандомное значение от 2 до 5 и суммируем элементы. В конце выводим сам массив и высчитываем среднюю оценку как среднее арифметическое чисел.


Составить программу на языке Паскаль для решения следующей задачи: Дан одномерный массив. В массиве
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота