Информатика, Бэйсик
Составить программу:
1)С клавиатуры вводится слово
Экран полностью очищается
Слово последовательно собирается по буквам в какой-либо строке, начиная с первой позиции. Каждая буква "приплывает" справа налево в свою позицию (т.е первая буква в первую позицию строки, вторая во вторую и т.д)
2) Составить программу по этому сценарию и произвести отладку программы
16
Объяснение:
Почти из всех населённых пунктов ведут по 3 дороги, исключениями являются только пункты К (из него ведут только 2 дороги) и Е (5 дорог). Сопоставив это с количеством непустых ячеек таблицы, можно определить, что пункт К соответствует П5, а пункт Е - П7.
По рисунку видно, что из пункта К (П5) ведут 2 дороги - одна в сторону Д и одна в сторону Е (П7). В то же время в таблице в строке П5 непустые значения имеются в пересечениях со столбцами П1 и П7 (уже известное Е), следовательно пункту Д соответствует П1.
Чтобы определить длину пути из Д в Е, найдём в таблице ячейку на пересечении П1 и П7, в ней находится значение 16.
Відповідь:
1.Дан массив из 8 элементов. Элементы вводятся с клавиатуры. Найти произведение четных элементов массива (четный элемент-если его номер делится на 2 с остатком 0)
#include <iostream>
using namespace std;
void cinarr(int *arr, const int SIZE){
int counter = 1;
for(int i = 0 ; i < SIZE ; i++){
cout << "Введите " << counter << " елемент: ";
cin >> arr[i];
counter++;
}
}
int sumev(int *arr,const int SIZE){
int sum = 0;
for(int i = 0 ; i< SIZE ; i++){
if(i % 2 != 0){
sum += arr[i];
}
}
return sum;
}
const int SIZE = 8;
int main() {
setlocale(LC_ALL , "Rus");
int arr[SIZE];
cinarr(arr,SIZE);
cout << "Сума парных елементов = " << sumev(arr,SIZE) << endl;
return 0;
}
2.Дан массив из 14 элементов. Элементы заполнены из промежутка 12;92. Найти сумму элементов
#include <iostream>
#include <cstdlib>
#include <time.h>
using namespace std;
void randarr(int *arr, const int SIZE){
for(int i = 0 ; i < SIZE ; i++){
arr[i] = rand() % 92 + 12;
}
}
void printarr(int *arr , const int SIZE){
for(int i = 0 ; i < SIZE ; i++){
cout << arr[i] << " ";
}
}
int sumelements(int *arr, const int SIZE){
int sum = 0;
for(int i = 0 ; i < SIZE ; i++){
sum += arr[i];
}
return sum;
}
const int SIZE = 14;
int main(){
setlocale(LC_ALL , "Rus");
srand(time(NULL));
int arr[SIZE];
randarr(arr,SIZE);
printarr(arr,SIZE);
cout << "\nСума всех елементов массива = " << sumelements(arr,SIZE) << endl;
return 0;
}
Пояснення: