В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lecsika
lecsika
18.03.2023 19:35 •  Информатика

ИНФОРМАТИКА ЭТО ЧЕРЕЗ ПАСКАЛЬ ДЕЛАТЬ
1)Написать программу, находящую периметр и площадь квадрата.

2)Написать программу, находящую сумму, разность, произведение и частное двух чисел.

Показать ответ
Ответ:
dreamsk831
dreamsk831
18.01.2022 10:47
Ну по логике, наверное, достаточно одного взвешивания. Получаем при этом некоторую массу в граммах. Затем смотрим, сколько нам не хватает граммов до 40 грамм - это и будет количество фальшивых монет.
Например:
Получили 40 г. Значит все 4 монеты весят 10 г.
Получили 39 г. Значит имеем три монеты по 10 г и одну 9 г. Т.е. одна фальшивая.
Получили 38 г. Значит имеем 2 монеты по 10 г и две по 9 г. Т.е. две фальшивки.
Получили 37 г. Значит одна 10 г и три по 9 г. Т.е. три фальшивки.
Получили 36 г. значит имеем 4 монеты по 9 г, то есть все 4 фальшивые.
Так вот как-то...
0,0(0 оценок)
Ответ:
DeadlyCrawley
DeadlyCrawley
18.02.2022 17:16

#include <iostream>

using namespace std;

int main()

{

 int a, b, c, febrary;

 bool isValid;

 //setlocale(LC_ALL, "Russian");

 cout << "Day:";

 cin >> a;

 cout << "Month:";

 cin >> b;

 cout << "Year:";

 cin >> c;

 if (c % 4 == 0)

   febrary = 29;

 else

   febrary = 28;

 isValid = true;

 if (b < 1 || b > 12)

   isValid = false;

 if (a < 1 || b > 31)

   isValid = false;

 if (b == 4 || b == 6 || b == 9 || b == 11)

   isValid = false;

 if (b == 2 && a > febrary)

   isValid = false;

 if (isValid)

   cout << "yes";

 else

   cout << "no";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота