ИНФОРМАТИКА КОД НА ПИТОН Слишком много платьев
Имя входного файла: стандартный ввод или stdin
Имя выходного файла: стандартный вывод или stdout
Ограничение по времени: 2 секунды
Ограничение по памяти: 64 мегабайта
Сёстры Рита и Берта живут в одной комнате и делят один шкаф на двоих. Они очень любят
новые наряды, и поэтому у них скопился целый шкаф платьев. Их настолько много, что иногда
девочки путаются и берут не своё платье. В последнее время у девочек появилось много свободного
времени, поэтому они решили навести порядок в шкафу.
Сейчас платья висят вперемешку. Девочки хотят развесить их так, чтобы сначала висели все
платья одной из девочек, а потом все платья другой. За одной действие можно достать одно платье
и повесить его обратно в шкаф на любое место Рите и Берте узнать, за какое минимальное количество действий они справятся с
наведением порядка в шкафу?
Формат входных данных
В первой строке содержится целое число n (1 ⩽ n ⩽ 50 000) — количество платьев в шкафу.
Во второй строке — строчка длины n, состоящая только из символов «R» и «B», означающих
платья Риты и Берты соответственно.
Формат выходных данных
Выведите одно число — минимальное число действий необходимых для упорядочивания платьев.
Примеры
стандартный ввод или stdin стандартный вывод или stdout
4
RBRB
1
8
BBRRBRBR
2
Точка с координатами (x, y) принадлежит области, если 0 <= x <= pi и 0 < y < sin(x), лежит на границе, если первое выполнено, и y = 0 или y = sin(x), а иначе не лежит в области.
Код (PascalABC.NET 3.2):
begin
var x, y: real;
readln(x, y);
if (0 <= x) and (x <= pi) then
if (0 < y) and (y < sin(x)) then
writeln('Внутри области')
else if (0 = y) or (y = sin(x)) then
writeln('На границе')
else
writeln('Не принадлежит')
else
writeln('Не принадлежит')
end.
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
tBook=record
author:string[30];
naim:string[50];
pages:integer;
godizd:integer
end;
begin
var f:file of tBook;
Rewrite(f,'books.dat');
Writeln('Ввод данных по книгам');
var s1,s2:string;
var i1,i2:integer;
var book:tBook;
repeat
s1:=ReadlnString('Автор или * для окончания ввода:');
if s1<>'*' then begin
s2:=ReadlnString('Название книги:');
i1:=ReadlnInteger('Количество страниц:');
i2:=ReadlnInteger('Год издания:');
(book.author,book.naim,book.pages,book.godizd):=(s1,s2,i1,i2);
Write(f,book)
end
until s1='*';
Writeln('*** Ввод завершен ***');
f.Close
end.
Тестовое решение
Ввод данных по книгам
Автор или * для окончания ввода: Жюль Верн
Название книги: 80 тысяч километров под водой
Количество страниц: 573
Год издания: 1951
Автор или * для окончания ввода: Сергей Лукьяненко
Название книги: Дозор
Количество страниц: 934
Год издания: 2004
Автор или * для окончания ввода: Жюль Верн
Название книги: Властелин мира
Количество страниц: 104
Год издания: 2011
Автор или * для окончания ввода: *
*** Ввод завершен ***
2. Программа для выборки
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
tBook=record
author:string[30];
naim:string[50];
pages:integer;
godizd:integer
end;
begin
var f:file of tBook;
Reset(f,'books.dat');
var s:=ReadlnString('Автор книги:');
var y:=Readinteger('Год издания, не ранее:');
var k:=0;
var book:tBook;
while not f.Eof do begin
Read(f,book);
if (book.author=s) and (book.godizd>=y) then begin
Writeln(book);
Inc(k)
end;
end;
if k=0 then Writeln('Таких книг не найдено');
f.Close
end.
Тестовое решение
Автор книги: Жюль Верн
Год издания, не ранее: 2005
(Жюль Верн,Властелин мира,104,2011)