В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
валера200331
валера200331
07.04.2023 00:45 •  Информатика

Информатика: напишите программу
дано действительное х. определить:
0,5х, если х> -2
f(x) = 1.
х”, в остальных случаях

Показать ответ
Ответ:
fox2457667
fox2457667
12.06.2020 15:22
1) 1000=120+110. Складываем в столбик.
  120
  110

1000
Во втором разряде справа 2+1 дало в результате 0. Но 2+1=3 в десятичной системе, следовательно система счисления троичная.

2) Если в мешке только красные яблоки, то вероятность вытащить красное яблоко равна единице и сообщение о том, какого цвета вытащенное яблоко не содержит никакой новой информации т.е. количество информации 0 бит. А если там есть яблоки другого цвета. то информации для решения задачи недостаточно.

3) Диапазон А1:С4 содержит четыре строки (1-4) и три колонки (А-С). Итого 4х3=12 ячеек.
0,0(0 оценок)
Ответ:
fifi17
fifi17
09.04.2023 01:23
В задании ошибка: Одномерный массив из 6 элементовПоменять местами 5-ый и 7-ой элементы 



#include <iostream>
#include <stdlib.h>      
#include <time.h>    

void Swap(int & a, int & b) {int t = a; a = b; b = t;}

int main(){
    srand(time(NULL));

    const int n = 6;
    int f[n], s[n];

    for (unsigned int i = 0; i < n; ++i) {
        f[i] = rand() % 12 + 5;
        s[i] = f[i];
    }

    // Меняем 5 и 6 элементы местами
    Swap(s[4], s[5]);
    s[3] *= 3;

    std::cout << "First: ";
    for (unsigned int i = 0; i < n; ++i) {
        std::cout << f[i] << ", ";
    }
    std::cout << std::endl;

    std::cout << "Second: ";
    for (unsigned int i = 0; i < n; ++i) {
        std::cout << s[i] << ", ";
    }
    std::cout << std::endl;
    return 0;
}
  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота