В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
aresha134589870
aresha134589870
13.04.2021 14:35 •  Информатика

Информатика, pascal, 1.составьте программу вычисления значения функции: у=5х2-4 / 2х+82.составьте блок-схему алгоритма и программу расположения трёх чисел в порядке возрастания.

Показать ответ
Ответ:
20Lorans03
20Lorans03
21.08.2021 11:53
Искренне надеюсь, что Вы сможете перевести этот код к нужному виду..:) В принципе, расхождения должны быть только в вводе/выводе (где Console.Бла-бла-бла) и генерации случайных чисел)

Sub Main()
        Dim a(29), Sum, Col As Integer
        Dim Rnd = New Random()
        For i As Integer = 0 To 29
            a(i) = Rnd.Next(-100, 100)
            Console.Write("{0} => {1}" + Environment.NewLine, i, a(i))
            If (i > 0) Then
                If (a(i) Mod a(0)) Then
                    Sum = Sum + a(i)
                    Col = Col + 1
                End If
            End If
        Next
        Console.WriteLine(Math.Round(Sum / Col, 2))
        Console.ReadKey()
    End Sub
0,0(0 оценок)
Ответ:
Artem58268343
Artem58268343
18.10.2022 18:14
Procedure swap(var a, b: real);
var t: real;
begin
     t := a;
     a := b;
     b := t;
end;

var a, b, c: real;
begin
     readln(a, b, c);
     if (a > b) then swap(a, b);
     if (b > c) then swap(b, c);
     if (a > b) then swap(a, b);
     writeln(a, ' ', b, ' ', c);
end.

Без процедур:

var a, b, c, t: integer;
begin
     readln(a, b, c);
     if (a > b) then
     begin
          t := a;
          a := b;
          b := t;
     end;
     if (b > c) then
     begin
          t := b;
          b := c;
          c := t;
     end;
     if (a > b) then
     begin
          t := a;
          a := b;
          b := t;
     end;
     writeln(a, ' ', b, ' ', c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота