В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Демон1997
Демон1997
13.01.2021 01:33 •  Информатика

Информатика, паскаль напишите программу, перемещающую все нулевые элементы в конец массива 80 очков,

Показать ответ
Ответ:
dadmaeva426
dadmaeva426
27.08.2020 12:13

const n = 10;

var

 mas: array [1..n] of integer;

 i,j,h:integer;

begin

randomize;

for i := 1 to n do

 begin

   mas[i] := random(3);

   write(' ',mas[i],' ');

 end;

 writeln();

for i := 1 to n - 1 do

 for j := 1 to n - i do

   if(mas[j] = 0) then

     begin

       h := mas[j];

       mas[j] := mas[j + 1];

       mas[j + 1] := h;

     end;

for i := 1 to n do

   write(' ',mas[i],' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота