В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nbkmrf
nbkmrf
12.05.2022 06:42 •  Информатика

Информатика! ПИТОН Строки

Я очень туплю

Значение выражения

Дана строка, состоящая из n цифр (т.е. однозначных чисел), между которыми стоит n−1 знак операции, каждый из которых может быть либо +, либо −. Вычислите значение данного выражения.

Входные данные

На вход подается строка, состоящая из цифр, а также символов + и −.

Выходные данные

Выведите ответ на задачу.

Примеры

Ввод

1+2-3

Вывод

0

Показать ответ
Ответ:
themaximka41
themaximka41
12.10.2020 03:04

https://onlinegdb.com/S1IjQ7SUU --- Код на Python в песочнице

Если нужен сам код сразу - она ниже (про отступы не забудь, если будешь копировать прямо отсюда):

row = str(input("Enter your math expression: "))

a = []

res = 0

for i in range(len(row)):

   a.append(row[i:i+1])

#    print(a[i])  --  Если хочешь посмотреть на результаты

#                     посимвольного разделения строки

#                     (больше для себя комментарий делал)

for i in range(len(row)):

   if (a[i] == "-"):

       res = res - (int(a[i+1]))

   elif (a[i] == "+"):

       res = res + (int(a[i+1]))

   elif (i == 0):

       res = res + (int(a[i]))

print("Resul of your math expression: ",res)

Если что, результати с консоли вывода тоже прикрепил

Удачи там с Python-ом ))


Информатика! ПИТОН СтрокиЯ очень туплюЗначение выраженияДана строка, состоящая из n цифр (т.е. одноз
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота