В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
otepovaaazan
otepovaaazan
16.10.2022 01:57 •  Информатика

Информатика ( Программирование ) - 7 класс Даны два целых числа A и B. Напишите программу без использования условного оператора "if", которая выводит все нечетные числа на отрезке от А до B. ( Программа должна быть написана на C++ ).

Входные данные:

На вход программе подаются два целых числа A и B (A≤B), по одному в строке.

Выходные данные:

Вывести через пробел все нечетные числа на заданном отрезке.

Пример:

Входные данные: (A = 1; B = 10)
Выходные данные: (1 3 5 7 9)

Показать ответ
Ответ:
Janna91
Janna91
22.12.2023 21:12
Хорошо, давайте начнем с написания программы на C++, которая будет выводить все нечетные числа на отрезке от A до B без использования условного оператора "if".

```c++
#include
using namespace std;

int main() {
int A, B;

// Ввод данных
cin >> A >> B;

// Рассматриваем каждое число на отрезке от A до B
for(int i=A; i<=B; i++) {
// Проверяем, является ли число нечетным
if(i%2 == 1) {
// Выводим нечетное число
cout << i << " ";
}
}

return 0;
}
```

В этой программе мы используем цикл `for`, чтобы рассмотреть каждое число от A до B.

Далее, для каждого числа на отрезке мы используем оператор `%` для проверки его четности. Если остаток от деления числа на 2 равен 1, то число нечетное и мы выводим его на экран.

Выводим все нечетные числа на отрезке через пробел.

Надеюсь, это поможет вам понять, как решить задачу. Если у вас есть еще вопросы, не стесняйтесь задавать!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота