В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
emiliskenderov
emiliskenderov
20.11.2020 03:49 •  Информатика

Информатика соч составьте программу для нахождения пути, пройденного транспортом, если известно время, проведенное в пути и ускорение транспорта

Показать ответ
Ответ:
Fomchenko1337
Fomchenko1337
16.03.2023 07:51
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('Укажите длины сторон прямоугольника:');
  Writeln('Площадь=',a*b,', периметр=',2*(a+b),
      ', диагональ=',Sqrt(a*a+b*b):0:5)
end.

Пример
Укажите длины сторон прямоугольника: 13.6 8.4
Площадь=114.24, периметр=44, диагональ=15.98499

begin
  var (a,b):=ReadReal2('Введите a и b:');
  Writeln('a+b=',a+b,', a*b=',a*b,', a/b=',a/b)
end.

Пример
Введите a и b: 134.23 -15.7
a+b=118.53, a*b=-2107.411, a/b=-8.54968152866242

begin
  var (a,b,c):=ReadReal3('Введите стороны треугольника:');
  var p:=(a+b+c)/2;
  Writeln('S=',Sqrt(p*(p-a)*(p-b)*(p-c)):0:3)
end.

Пример
Введите стороны треугольника: 13 8 11.3
S=44.843
0,0(0 оценок)
Ответ:
Alina970azhieva
Alina970azhieva
16.03.2023 07:51
Все в паскале:
1. Формула пути S=V*t,V=S/t;
    Значит программа имеет вид
var s, v, t:integer;
begin
writeln('Введите путь и время');
readln(s, t);
v:=s/t
writeln('ответ: V=', v);
end.
Все остальное по анологии

Во 2 и 3 y:=/формула в условии/ и выводишь у
В 4, воспользуйся формулой площади S=a*b (a и b - ширина с длинной)
В 5 a=P-2*b  (а основание, b бок сторона)
В 7 o=(a+b+c)/3 (о - ср., а, b, c - число в классах)
8.
var a, b:integer;
begin
writeln('Введите числа');
readln(a, b);
writeln('Сумма=', a+b);
writeln('Разность=', a-b);
end.
В 9 как 8, только вместо + и - надо * И /
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота