В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Информатика. в ! «составить программу, которая формирует двумерную матрицу случайных чисел, имеющих n строк и n столбцов, а затем формирует два одномерных массива. причём в один записываются элементы матрицы, расположенные на главной диагонали и выше, а в другой - элементы матрицы, лежащие ниже главной диагонали и выводит все массивы на экран.» хоть кто-нибудь , ну всё запущено : (

Показать ответ
Ответ:
Anna128376373
Anna128376373
08.06.2020 20:19

Объяснение:

program matic1;

const z=100;

type mas=array[1..z] of integer;

type mas2=array[1..z,1..z] of integer;

var

u :mas2;

u1, u2: mas;

n,k,m:integer;

procedure ch1(n:integer);

var i,j:integer;

begin

j:=0;k:=0;m:=0;

randomize;

for i:=1 to n do

for j:=1 to n do

   u[i,j]:= random(20+j)+20;

for i:=1 to n do

for j:=1 to n do

  begin

  if j>=i then begin k:=k+1;u1[k]:=u[i,j] end

  else begin m:=m+1;u2[m]:=u[i,j] end;

  end;

  end;

// Вывод 2 мерного массива на экран

// a -массив n-размер,text - что хотим написать

procedure showmas2(b:mas2;n:integer;text:string);

var

i,j:integer;

begin

writeln(text);

for i:=1 to n  do

for j:=1 to n do

if j<>n then write(b[i,j],' ') else writeln(b[i,j],' ');

readln;

end;

// Вывод 1 мерного массива на экран

// a -массив nn-размер,text - что хотим написать

procedure showmas(b:mas;nn:integer;text:string);

var

i:integer;

begin

writeln(text);

for i:=1 to nn  do

write(b[i],' ');

readln;

end;

begin

Write('Введите размер массива N= ');

readln(n);

ch1(n);

showmas2(u,n,'Исходная матрица NxN u');

showmas(u1,k,'Элементы главной диагонали и выше u1');

showmas(u2,m,'Элементы ниже главной диагонали  u2');

readln;

end.

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота