В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
taukebai2002
taukebai2002
09.09.2020 15:01 •  Информатика

Исполнитель умеет выполнять два действия: «+1», «*2». Составьте программу получения из числа 1 числа 100. Pascal

Показать ответ
Ответ:
1232959
1232959
05.05.2023 13:00
1.
A = 0,5; B = -1,7;
Так как A больше B, то идем по ветке "else":
B = A;
B = 0,5.

ответ: A = 0,5; B = 0,5.

2. Так как "6" больше "16", то идем по ветке "then":
C = 5.

ответ: 5.

3. Если между выражениями стоит "and", то они оба должны выполняться (1), если хоть одно из них ложно, то программа выдаст "ложь" (0).

При x = 5 первое выражение будет истинным, но во втором ложным, т.к. пять не больше пяти. Две скобки не истинны - значение выражения "ложь" (0).

ответ: 0.

4. mod - остаток от деления.
abs - модуль числа.

Если между выражениями стоит "or", то при одной или двух истинных выражениях программа на выходе дает "истину" (1). Если обе скобки ложны, то программа возвращает "ложь" (0).

При делении 45 на 2, остатком от деления является 1, а не 0. Скобка считается ложной.

При abs (45) число вправду больше 35, начит скобка истинна.

В итоге логическое выражение принимает значение "1".

ответ: 1.

5. (x <= 2) or (x > 15).
Or - или.
0,0(0 оценок)
Ответ:
AnyaFOX9
AnyaFOX9
23.02.2021 03:06
Язык C++.
#include <iostream>
using namespace std;
int main(){
    int a, b, c, d;
    cout << "Введите длины сторон попарно: " << endl;
    cin >> a >> b >> c >> d;
    if(a == b && a==c && a==d && c==b && c==d && b==d)
    cout << "Квадрат или ромб." << endl;
    else if (a==b && c==d)
    cout << "Прямоугольник или параллелограмм." << endl;
    else
    cout << "Трапеция или произвольный четырехугольник." << endl;
    }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота