В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Используя цикл «for», написать программу на языке С++ для решения следующей задачи: Среди всех двузначных чисел найти количество таких, у которых сумма цифр кратна 3. Например, у числа 27 сумма цифр 2+7 = 9, т.е. кратна 3, а у числа 25 сумма цифр 2+5 = 7 не кратна 3. Определите, сколько чисел удовлетворяет задачи.

Показать ответ
Ответ:
Lsjsjajj
Lsjsjajj
16.04.2021 19:15

int sum = 0;

for (int i=10, i<=99, i++) {

if ((i%10 + i/10) % 3 == 0) {

sum += 1;

}

}

cout << sum;

Если есть вопросы по коду - пиши в комментарии

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота