В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
helpme168
helpme168
11.06.2020 23:51 •  Информатика

Используя команду "повернуть в направлении",напишите программу,рисующий орнамент ​


Используя команду повернуть в направлении,напишите программу,рисующий орнамент ​

Показать ответ
Ответ:
ladykaden
ladykaden
11.12.2022 11:27
#include "stdafx.h"#include <iostream>#include <windows.h>#include <ctime>using namespace std;int main(){ SetConsoleCP(1251); SetConsoleOutputCP(1251); srand(time(0)); int n,t; double ot=0, pol=0, nol=0; cout << "Введите размер массива " << endl; cin >> n; double *core = new double[n]; for (int i = 0; i < n; i++) { cout << "Введите элемент " << endl; cin >> core[i]; } for (int i = 0; i < n; i++) { if (core[i] < 0) { ot++; } if (core[i] > 0) { pol++; } if (core[i] == 0) { nol++; } } cout << "Положительных: " << pol << ", отрицательных: " << ot << ", нулей:" << nol << endl;}
0,0(0 оценок)
Ответ:
jokerreal30
jokerreal30
17.02.2020 10:00

Компьютерные словари. Словари необходимы для пере­вода текстов с одного языка на другой. Первые словари были созданы около 5 тысяч лет назад в Шумере и представ­ляли собой глиняные таблички, разделенные на две части. В одной части записывалось слово на шумерском языке, а в другой — аналогичное по значению слово на другом язы­ке, иногда с краткими пояснениями.

Современные словари построены по такому же принци­пу. В настоящее время существуют тысячи словарей для перевода между сотнями языков (англо-русский, немец­ко-французский и т. д.), причем каждый из них может со­держать десятки тысяч слов. В бумажном варианте словарь представляет собой толстую книгу объемом в сотни страниц, в которой поиск нужного слова — процесс достаточно трудо­емкий.

Компьютерные словари могут содержать переводы на разные языки сотен тысяч слов и словосочетаний, а также предоставляют пользователю дополнительные возможности:

•существуют многоязычные компьютерные словари, позволяющие пользователю выбрать языки и направ­ление перевода (например, англо-русский, испано-рус­ский и т. д.); •компьютерные словари могут кроме основного словаря общеупотребительных слов содержать десятки специа­лизированных словарей по областям знаний (техника, медицина, информатика и др.); •компьютерные словари обеспечивают быстрый поиск словарных статей: «быстрый набор», когда в процессе набора слова возникает список похожих слов; доступ к часто используемым словам по закладкам; возмож­ность ввода словосочетаний и др.; •компьютерные словари могут являться мультимедий­ными, т. е. предоставлять пользователю возможность

прослушивания слов в исполнении дикторов, носите­лей языка;

• онлайновые компьютерные словари в Интернете обес­печивают выбор тематического словаря и направления перевода.

Системы компьютерного перевода. Происходящая в на­стоящее время глобализация нашего мира приводит к необ­ходимости обмена документами между людьми и организа­циями, находящимися в разных странах мира и говорящими на различных языках.

В этих условиях использование традиционной техноло­гии перевода «вручную» тормозит развитие межнациональ­ных контактов. Перевод многостраничной документации вручную требует длительного времени. Перевод полученного по электронной почте письма или просматриваемой в брау­зере Web-страницы необходимо осуществить «здесь и сей­час», и нет возможности и времени пригласить переводчика.

Системы компьютерного перевода позволяют решить эти проблемы. Они, с одной стороны переводить мно­гостраничные документы с высокой скоростью (одна страни­ца в одну секунду), с другой стороны, переводить Web-стра­ницы «на лету», в режиме реального времени.

Системы компьютерного перевода осуществляют пере­вод текстов, основываясь на формальном «знании» языка: синтаксиса языка (правил построения предложений), пра­вил словообразования и использовании словарей. Програм­ма-переводчик сначала анализирует текст на одном языке, а затем конструирует этот текст на другом языке.

Онлайновые компьютерные переводчики в Интернете обеспечивают выбор тематического словаря и направления перевода. Они позволяют переводить любые тексты, набран­ные в окне перевода или скопированные из буфера обмена, Web-стракицы, включая гиперссылки, с сохранением исход­ного форматирования, а также электронные письма.

Современные системы компьютерного перевода позволя­ют с приемлемым качеством переводить техническую доку­ментацию, деловую переписку и другие специализированные тексты. Но на эти системы нельзя полностью полагаться. Они допускают смысловые и стилистические ошибки и непри­менимы, например, для перевода художественных произве­дений, так как не адекватно переводить метафоры, аллегории и другие элементы художественного творчества человека и т. д.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота