В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
NastyaDersen2004
NastyaDersen2004
10.03.2020 16:06 •  Информатика

Используя материал конспекта написать программу для решения следующей задачи: Дано целое число n = 1..3, которое есть номером функции. По значению переменной n вычислить значения соответствующей функции: 1) x^2+4; 2) -10x-1; 3) 7-x.

Показать ответ
Ответ:
balbasenok
balbasenok
19.10.2020 08:08
1. Программа на Питоне, подсчитывающая все слова:
word = "abracabra"
n = len(word)
words = set([word])
to_proceed = [word]
while len(to_proceed) > 0:
    word = to_proceed.pop()
    for l in range(n):
        for r in range(l + 1, n + 1):
            new_word = word[:l] + word[l:r][::-1] + word[r:]
            if new_word not in words:
                words.add(new_word)
                to_proceed.append(new_word)
print(len(words))

2. Комбинаторика: такими операциями можно получить любую перестановку букв исходного слова (переворачиваем подстроку [1:n], затем [2:n], получаем слово, в котором на 1 месте стоит n-й символ. Такими операциями можно последовательно на все места поставить любые символы). Подсчитаем число слов:
- места для 4 букв a можно выбрать
- 2 буквы b на оставшиеся 5 мест можно поставить
- 2 буквы r на оставшиеся 3 места можно поставить
- место для c определяется однозначно
Всего

ответ: 3780
0,0(0 оценок)
Ответ:
DariaBlack777
DariaBlack777
19.10.2020 08:08
Прямоугоьник   Ластик.                                                                                         Кисть Лупа.                                                                                                           Заливка Выделить.                                                                                                Карандаш.                                                                                                             Линия.                                                                                                                   Мноугольник.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота