Используя материалы уроков, составьте программу на языке Pascal. Ввод и вывод данных в программе, должен осуществляться в окне консоли crt, для которого задать размеры окна: 80 колонок на 32 строки; цвет фона - синий; цвет текста - белый. При составлении программы использовать операторы цикла while или repeat.
Сохранить файл программы и прикрепить к этому вопросу.
ЗАДАНИЕ:
Составить программу вычисления банковского процента по займу за указанный период.
Исходные данные:
- сумма займа
- годовой процент по займу
- срок займа(в годах)
сумма займа выплачивается равномерно за каждый перод выплат - один год.
Результат выполнения программы:
- за каждый период выплат(один год) вычислить и вывести на экран сумму процентов и сумму выплаты.
- вычислить итоговую сумму выплаты по всему займу и сумму переплаты.
begin
s:=0; k:=0;
for i:=1 to 9 do
for j:=0 to 9 do
begin
s:=s+i*100+j*10+i;
k:=k+1;
end;
writeln('s = ',s,' k = ',k,' sred = ',s/k:6:2);
end.
Результат:
s = 49500 k = 90 sred = 550.00
Если нужно приложение с формой, то:
помещаете на форме командную кнопку (Button) и статичный текст (StaticText).
В обработчик кнопки добавляете код:
procedure TForm1.Button1Click(Sender: TObject);
var i,j,s,k:integer; s:string;
begin
s:=0; k:=0;
for i:=1 to 9 do
for j:=0 to 9 do
begin
s:=s+i*100+j*10+i;
k:=k+1;
end;
s:='s = '+IntToStr(s)+' k = '+IntToStr(k)+' sred = '+FloatToStr(s/k);
StaticText1.Caption := s;
end;
begin
s:=0; k:=0;
for i:=1 to 9 do
for j:=0 to 9 do
begin
s:=s+i*100+j*10+i;
k:=k+1;
end;
writeln('s = ',s,' k = ',k,' sred = ',s/k:6:2);
end.
Результат:
s = 49500 k = 90 sred = 550.00
Если нужно приложение с формой, то:
помещаете на форме командную кнопку (Button) и статичный текст (StaticText).
В обработчик кнопки добавляете код:
procedure TForm1.Button1Click(Sender: TObject);
var i,j,s,k:integer; s:string;
begin
s:=0; k:=0;
for i:=1 to 9 do
for j:=0 to 9 do
begin
s:=s+i*100+j*10+i;
k:=k+1;
end;
s:='s = '+IntToStr(s)+' k = '+IntToStr(k)+' sred = '+FloatToStr(s/k);
StaticText1.Caption := s;
end;