В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nyamnov
nyamnov
23.01.2023 14:15 •  Информатика

Используя оператор case , напишите программу, которая переводит десятичные числа 1, 5, 10, 50, 100, 500, 1000, считываемые с клавиатуры, в римские.

Показать ответ
Ответ:
VikiNiki23
VikiNiki23
24.05.2020 00:36

include <iostream>

using namespace std;

int main()

{int n;

 cin >> n;

switch(n)

        {case 1:cout<<"I";break;

         case 5:cout<<"V";break;

         case 10:cout<<"X";break;

         case 50:cout<<"L";break;

         case 100:cout<<"C";break;

         case 500:cout<<"D";break;

         case 1000:cout<<"M";break;

        }

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота