ивт сделать 1 задания . Составьте программу, выводящую на экран квадраты чисел в строку от 10 до 20 включительно, используя цикл с параметром. Результат программы: 100, 121, 144, 169, 196, 225, 256, 289, 324, 361, 400
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017 // Внимание! Если программа не работает, обновите версию!
uses NumLibABC;
begin var (num,denom):=ReadInteger2('Числитель и знаменатель 1-й дроби:'); var f1:=Frc(num,denom); (num,denom):=ReadInteger2('Числитель и знаменатель 2-й дроби:'); var f2:=Frc(num,denom); f1.Print; Write('* '); f2.Print; Write('= '); (f1*f2).Print end.
Примеры Числитель и знаменатель 1-й дроби: 4 9 Числитель и знаменатель 2-й дроби: 3 8 4/9 * 3/8 = 1/6
Числитель и знаменатель 1-й дроби: 32432424 10213133 Числитель и знаменатель 2-й дроби: 23123 12313123 32432424/10213133 * 23123/12313123 = 749934940152/125755562844359
Числитель и знаменатель 1-й дроби: 15 2 Числитель и знаменатель 2-й дроби: 8 15 15/2 * 8/15 = 4
800*600*16 (16 бит на пиксель это 65 536 цветов)=7680000 - бит информационный вес одного поля кадра.
Допустим частота обновления экрана монитора 60 Гц, тогда
7680000*60 (Гц)=460800000 бит в секунду * 60 (секунд)= 27648000000 бит - информационная емкость потока фильма в течении 1 минуты.
Постичаем в байтах
27648000000/8/1024/1024/1024=3.2186 Гигабайт - объём информационного потока
Задача №3
за одну секунду пройдет 36 мегабайт
2 часа = 7200 секунд *36=259200 мегабайт=253.12 Гбайт
Р.S. Это только в файле ваши фильмы нетакие большие, а при проигрывании при декомпрессии по шине памяти и по вашим HDMI проводам именно такие потоки и идут
// Внимание! Если программа не работает, обновите версию!
uses NumLibABC;
begin
var (num,denom):=ReadInteger2('Числитель и знаменатель 1-й дроби:');
var f1:=Frc(num,denom);
(num,denom):=ReadInteger2('Числитель и знаменатель 2-й дроби:');
var f2:=Frc(num,denom);
f1.Print; Write('* '); f2.Print; Write('= '); (f1*f2).Print
end.
Примеры
Числитель и знаменатель 1-й дроби: 4 9
Числитель и знаменатель 2-й дроби: 3 8
4/9 * 3/8 = 1/6
Числитель и знаменатель 1-й дроби: 32432424 10213133
Числитель и знаменатель 2-й дроби: 23123 12313123
32432424/10213133 * 23123/12313123 = 749934940152/125755562844359
Числитель и знаменатель 1-й дроби: 15 2
Числитель и знаменатель 2-й дроби: 8 15
15/2 * 8/15 = 4
Задача №2
800*600*16 (16 бит на пиксель это 65 536 цветов)=7680000 - бит информационный вес одного поля кадра.
Допустим частота обновления экрана монитора 60 Гц, тогда
7680000*60 (Гц)=460800000 бит в секунду * 60 (секунд)= 27648000000 бит - информационная емкость потока фильма в течении 1 минуты.
Постичаем в байтах
27648000000/8/1024/1024/1024=3.2186 Гигабайт - объём информационного потока
Задача №3
за одну секунду пройдет 36 мегабайт
2 часа = 7200 секунд *36=259200 мегабайт=253.12 Гбайт
Р.S. Это только в файле ваши фильмы нетакие большие, а при проигрывании при декомпрессии по шине памяти и по вашим HDMI проводам именно такие потоки и идут