Изучите блок-схему и напишите программу на языке С++ в среде Code Blocks
#include
using namespace std;
int main ()
{int ответ
, ответ
;
S = ответ
;
for (i=ответ
; ответ
<=ответ
; i+=ответ
)
{
S=ответ
;
}
cout << "S= " << ответ
;
return 0;
}
Рассчитайте и укажите какое получится значение S = ответ
Исправьте фрагменты программы, содержащие пустые окна на соответствующий код для получения результата решения данной задачи.
Для ответов воспользуйтесь следующими словами и данными, вписав их в пустые окна ответов (величина рассчитанного значения S не указана):
S (использовать 3 раза)
i (использовать 3 раза)
0 (использовать 2 раза)
2 (использовать 1 раз)
20 (использовать 1 раз)
+ (использовать 1 раз)
using namespace std;
int main() {
int mat[3][3];
int k;
int size=0;
int * arr=0;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cin>>mat[i][j];
if (mat[i][j]>0){
arr=(int*)realloc(arr,sizeof(int)*(++size));
arr[size-1]=mat[i][j];
}
}
}
for(int i=0;i<size;i++){
cout<<arr[i];
}
delete arr;
cin.get();
cin.get();
return 0;
}
дешифровки:
Const sh = '_.,';
Var
St : String;
i : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
For j:=1 to Length(S) do
Begin
n:=Pos(S[j],sh);
If n>0 then
Begin
n:=n+k;
While n>Length(sh) do n:=n-Length(sh);
While n<=0 do n:=n+Length(sh);
S[j]:=sh[n];
end
end;
DeCode:=S;
end;
Begin
St:='ЗЫФЙГФШРЦ . ШД';
Writeln(Decode(St,sh,-6));
//For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.